Update движка форума


#1

Обновлен движок форума, до версии 3.0.5
Надеюсь, это на некоторое время поможет от рекламных ботов с порнухой.
В этой теме отписываем о замеченных глюках.

Новые возможности и важные изменения:

[ul]Added an option to the registration screen to allow users to refresh the displayed CAPTCHA.
Performance improvements for native fulltext search.
Addeda new search option. The admin can define the maximum number of wordsallowed to search for. This option gives control about the maximumsearch load.
Search indexing should no longer stall for some installations.
Conflicting files are able to be downloaded now within the automatic updater for manual inspection.
Thedatabase updater now checks for an incompatible database schema in casethe database version got updated. The admin will be notified aboutpossible solutions and repair scripts.
We now set theconnection encoding for MySQL versions 4.1.0 to 4.1.2. This may fixsome conversion issues with special characters.
Language pack authors now see errors/notices within their language pack if they enabled DEBUG_EXTRA.
Flash files now display again after update to flash player 10.
[/ul]
Список важных изменений по сравнению с версией 3.0.4:

[ul][Fix] Delete user entry from ban list table upon user deletion (Bug #40015 - Patch by TerraFrost)
[Fix] Posts incremented for multiple approval of the same topic (Bug #40495 - Patch by TerraFrost)
[Fix] Missing end " in quote bb tag deletes text (Bug #40565 - Patch by TerraFrost)
[Fix] Friend/foe system displays posts made by foes while composing (Bug #40325 - Patch by TerraFrost and Highway of Life)
[Fix] Check forum_image whether it exists (Bug #39005 - Patch by TerraFrost)
[Fix] The sql query in acp_users.php lacks a condition (Bug #40275 - Patch by grimskies)
[Fix] Added missing read permission information for some phpbb_chmod() calls
[Fix] Correctly display future dates (Bug #38755)
[Fix] Fix guest/bot session problems with apache authentication plugin (Bug #41085)
[Fix] Whois now works reliably for RIRs other than APNIC and RIPE. (Bug #40085)
[Fix] Correctly convert Niels’ Birthday MOD to the date format used in phpBB3. (Bug #32895)
[Fix] Changed the success message when requesting a new password to be more accurate. (Bug #41405)
[Fix] Add missing anti-abuse email headers to acp_inactive.php and ucp_resend.php.
[Fix] Only remind users in the correct inactive states depending on the board account activation level.
[Fix]Various XHTML mistakes in prosilver, subsilver2 and the ACP. (Bugs#41745, #42265 - Patch by nickvergessen, #38465, #43015)
[Fix] Log password changes via password reset function. (Bug #41365)
[Fix] Poll, negative durations generate error (Bug #41295 - Patch by TerraFrost)
[Fix]Visibility of custom field on registration is incorrectly controlled bysetting “display” (Bug #41385 - Patch by Eelke and fade2gray)
[Fix] Smilies in username are misparsed on [quote=""] (Bug #41955 - Patch by TerraFrost)
[Fix] Deleting all posts in a topic - bad redirect (Bug #41705 - Patch by TerraFrost)
[Fix] Deleted users still appear logged in (Bug #41985 - Patch by TerraFrost)
[Fix] Removed redundant code and unnecessary queries in forum management. (Bug #42265 - Patch by nickvergessen)
[Fix]Correct mbstring regular expression for the allowable usernamecharacters, only affects USERNAME_LETTER_NUM_SPACERS. (Bug #42325)
[Fix] Fix infinite loop in message handler if cache directory is not writable. (Bug #38675)
[Fix] While post is awaiting approval it can still be edited even though it can not be seen (Bug #41435 - Patch by TerraFrost)
[Fix]Fix imageset editing for retaining and correctly setting dimensions forimages, as well as displaying correct settings for first page load.
[Fix] Use OS-specific line endings for mail headers. (related to Bug #42755)
[Fix] Hide font size options which are bigger than the allowed size in the editor. (Bug #42615 - Patch by nickvergessen)
[Fix] Better thumbnail quality with imagemagick. (Bug #42565)
[Fix] Fix download count increments for image attachments without corresponding thumbnails. (Bug #42505)
[Fix] Fix wrong bot ip check if bot ip was wrongly entered by admin. (Bug #42485)
[Fix] Fix javascript errors in simple header (prosilver) by adding forum_fn.js and the corresponding variables. (Bug #42135)
[Fix]Set connection encoding for MySQL versions 4.1.0 to 4.1.2. This may fixsome conversion issues with special characters. (Bug #41805)
[Fix] Deleting private message attachments could delete post attachments. (Bug #42815)
[Fix] Do not suppress PHP notices/errors in language packs if DEBUG_EXTRA mode enabled. (Bug #41485)
[Fix] Flash files do not display anymore after update to flash player 10 (Bug #41315)
[Fix] Use FQDN for SMTP EHLO/HELO command. (Bug #41025)
[Fix] Mass Email works again for users with empty jabber address but notification set to ‘both’. (Bug #39755)
[Fix] Fix race condition for updating post/topic/etc. counter. (Reported by BartVB)
[Fix] Fix duplicate creation of acl options in acl_add_options() under certain conditions. (Bug #38385, #40225)
[Fix]Cancel when replying to global announcement redirects to first forum -not to the current forum (Bug #41225 - Patch by TerraFrost)
[Fix] Cursor Jumps on New Topic in IE (Bug #42455 - Patch by TerraFrost)
[Fix] Add indicator to be used in code if session was created (user visits the site for the first time).
[Fix] Correctly count topic views for guests visiting the website the first time by entering the topic directly (Bug #43445)
[Fix] Fix bug in postgresql db layer for LIMIT ALL clauses (Reported by JRSweets)
[Fix] Sort backups by date, newest first (Bug #14818)
[Fix]Prevent incomplete backups stored if option “store and download” isselected and admin cancel download by removing the option. (Bug #20325)
[Fix] Enforce correct case for template variables
[Fix]Set topic_last_view_time on post/reply/edit to circumvent raceconditions in auto prune and false removal of topics for manual forumprune (Bug #18055, #43515)
[Fix] Correctly split long subject lines according to the used RFC. This fixes extra spaces within long subjects. (Bug #43715)
[Fix] Fix skipping messages if using next/prev PM in history links. (Bug #22205)
[Fix] Messenger now also able to use a custom language path. (Bug #36545)
[Fix] PM Export uses ISO 8601 date now. (Bug #32645)
[Fix] Apply append_sid() to newest/latest post links in viewforum/search and UCP main module. (Bug #26815)
[Fix] Do not create thumbnail if thumbnail would’ve the same size as the original image. (Bug #30725)
[Fix] Ability to vote in poll is now required for the ability to change existing vote. (Bug #38925)
[Fix] Search for ‘topic title only’ and ‘first post’ should work again for non-mysql dbms. (Bug #40605)
[Fix] Make sure additional information for accessibility is always exposed to screen readers (Bug #44335 - Patch by MarcoZ)
[Fix] Approving a topic when some of the posts within that topic have already been approved (Bug #42585 - Patch by TerraFrost)
[Fix] Online status shown when post hidden (Bug #35505 - Patch by Raimon)
[Fix] memberlist.php display formating can be distorted by posting long URL for website (Bug #36675 - Patch by TerraFrost)
[Fix] Display the online status of hidden users to users with the u_viewonline permission when viewing PMs.
[Fix] “Select all” selects much too much in Opera (Bug #42885 - Patch by TerraFrost and ToonArmy)
[Fix] Correct calculation of source/target forum statistics if mass moving topics with global announcements (Bug #44545)
[Fix] Fix column handling in db updater, custom profile fields and db tools for firebird DBMS (Bug #44555)
[Fix] IE8 textarea issues (Bug #43305)
[Fix] Prevent accounts from being activated by users when admin activation is turned on and the correct activation key is known.
[Fix] Allow the installer to operate under PHP 5.3. (Bug #45255)
[Change] Default difference view is now ‘inline’ instead of ‘side by side’
[Change] Added new option for merging differences to conflicting files in automatic updater
[Change] Add link to user profile in the MCP for user notes and warn user.
[Change] Add IN_PHPBB check to generated cache files. (Reported by bantu)
[Change] Add topic icons to prosilver UCP main and subscribed templates (Bug #42735 - Patch by Raimon)
[Change] Add unique key to ACL options table to prevent duplicate permission options. (Bug #41835)
[Change] Redirect to relevant MCP page of multi-page topic if accessing quickmod tools (Split option for example)
[Change] Performance improvements for native fulltext search (Patch by Paul)
[Change] Changed jumpto() JS function to be more fail-safe. (But #27635 - Patch by peterkclee)
[Feature] Added new options for visual confirmation.
[Feature] Allow download of conflicting file for later reference in automatic updater
[Feature] Allow translation of custom BBCode help messages. (Patch by bantu)
[Feature] db_tools now support create table and drop table.
[Feature] Database updater checks for incompatible db schema (MySQL 3.x/4.x against MySQL 4.1.x/5.x/6.x)
[Feature] New search option: Maximum number of words allowed to search for.
[Sec] Only use forum id supplied for posting if global announcement detected. (Reported by nickvergessen)[/ul]


#2

Спасибо, Паш.


#3

совершенно не очет работать под Safari 4


#4

а 3.0.4 работал?


#5

да. ща попробую скрин сделать.


#6

Black Priest , при клике по нику вставляется только тег [b]
а ещё при открытии топика курсор вставляется в “быстрый ответ” и падаешь сразу в конец странички. Вроде ж неудобно, или так задумывалось?


#7

а еще при нажатии на “Цитата” не вставляется автор слов! Как-то не очень удобно, приходится копи-паст делать дополнительно…


#8

в ближайшее время будет исправлено

не смог повторить, опиши подробнее что делаешь

[size=85][color=#008000]PS перенесено в более подходящую тему тк глюки связаны с апдейтом движка[/color][/size]


#9

когда захожу в топик или в топике перехожу на другую страничку, то после того как всё загрузится - курсор становится туда, где надо писать быстрый ответ. И каждый раз приходится скролить вверх.


#10

Сколько не старался, мне никак не удалось повторить твой трюк. Все открывается в начале страницы или на первом непрочитанном сообщении (смотря куда ткнуть). А как у тебя ни разу не получалось…
Каким браузером пользуешься? В других браузерах проблема та же?


#11

IE 8.0
PS: сейчас попробовал оперу и мозилу - такого нет. Значит глюк моего браузера :frowning:


#12

Обновлен движок форума, до версии 3.0.7-PL1

отписываем о замеченных глюках.

Изменения, по сравнению с версией 3.0.5 >>>

fixed

fixed


#13

а можно сделать, чтобы видео в посте вставлять?


#14

:roll: какие то они странные


#15

БОЛЕЕ актуальная информация по встраиванию видео в этом посте

Да пожалуйста!
пример:

[youtube]http://www.youtube.com/watch?v=xL5qTVunzcE[/youtube]

добавил смайлики в форму быстрого ответа


#16

Не получилось у меня:
viewtopic.php?f=2&t=48&p=11258#p11258


#17

youtube.com/watch?v=3_tDYw9C8Ws&feature=player_embedded
Кусок в ссылке лишний


#18

Mr.Zet, спасибо, исправил


#19

Обновлен движок форума, до версии 3.0.8

Изменения по сравнению с предыдущей версией >>

  • добавил текстовое подтверждение при регистрации (ответ на простой вопрос) для защиты от автоматической регистрации спам-ботов

О замеченных глюках пишите в этой теме.


#20

Выкачена версия 3.0.10
changelog

Начал перенос форума на новый хостинг на Amazon, начинка полностью на новом железе, жду пока домен переделегируется на новые ns-сервера

Предложения по новым фичам и замеченным багам можно постить в этот топик :slight_smile: